Monday, March 12, 2012

IronPython 2.7.2.1

There was fairly serious regression introduced between 2.7.2 RC1 and 2.7.2 final – see issue #32400 for details. Upgrading to 2.7.2.1 is highly recommended.

On the plus side, this isn’t a dataloss bug, or anything like that, just a “break almost every program in existence” bug. Basically, the code for checking for comparison operators got broken. The motivating example is

if sys.version_info < (2, 4):
# do something

I’m sure other cases would be broken as well, so I decided to err on the side of caution and update the release as soon as possible. My apologies to everyone who already downloaded 2.7.2 and was impacted by this.

No comments:

Post a Comment